<!DOCTYPE html>
<html lang="en" dir="ltr" prefix="og: https://ogp.me/ns#">
  <head>
    <meta charset="utf-8" /><script type="text/javascript">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</script>
<script type="text/javascript">var turner_metadata = {"page_name":"2020 dii football schedule: dates, times, matchups | ncaa.com","keywords":"college football, college football schedule, dii football, dii football schedule","url":"https:\/\/www.ncaa.com\/news\/football\/article\/2020-10-27\/2020-dii-football-schedule-dates-times-matchups","article_name":"2020 dii football schedule: dates, times, matchups","article_published_time":"2020-10-27t12:11:15z","article_modified_time":"2020-10-27t12:11:15z","article_tag":"college football, college football schedule, dii football, dii football schedule","author":"zach pekale | ncaa.com","business_unit":"ncaa","content_type":"article","division":"d2","franchise":"article","gender":"men","node_id":"2044036","section":"football-men-d2","subsection":"article","sport":"football","sport_div":"football-d2","thumbnail_url":"https:\/\/www.ncaa.com\/_flysystem\/public-s3\/styles\/large_16x9\/public-s3\/images\/2020-10\/Ahmad-Lewis-South-Dakota-Mines-football.jpeg?h=7ee21c69&amp;itok=sfsi0EKW","date_created":"2020-10-27T12:10:00Z","date_published":"2020-10-27T12:11:15Z","date_modified":"2020-10-27T12:11:15Z"};</script>
<link rel="canonical" href="https://www.ncaa.com/news/football/article/2020-10-27/2020-dii-football-schedule-dates-times-matchups" />
<meta name="description" property="description" content="Here is the DII college football schedule for every week and game times of the 2020-21 season." />
<meta name="abstract" content="Here is the DII college football schedule for every week and game times of the 2020-21 season." />
<meta name="twitter:image:alt" content="South Dakota Mines running back Ahmad Lewis ran for more than 1,300 yards in 2019." />
<meta name="Generator" content="Drupal 8 (https://www.drupal.org)" />
<meta name="MobileOptimized" content="width" />
<meta name="HandheldFriendly" content="true" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<link rel="dns-prefetch" href="//consent.truste.com" />
<link rel="dns-prefetch" href="//agility.ncaa.com" />
<link rel="preconnect" href="//cdn.cookielaw.org" />
<link rel="preconnect" href="//static.chartbeat.com" />
<link rel="preconnect" href="//ping.chartbeat.net" />
<link rel="preconnect" href="//mabping.chartbeat.net" />
<link rel="preload" href="/core/assets/vendor/jquery/jquery.min.js?v=3.4.1" as="script" type="application/javascript" />
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","headline":"2020 DII football schedule: Dates, times, matchups","url":"https:\/\/www.ncaa.com\/news\/football\/article\/2020-10-27\/2020-dii-football-schedule-dates-times-matchups","dateCreated":"2020-10-27T12:10:00Z","datePublished":"2020-10-27T12:11:15Z","dateModified":"2020-10-27T12:11:15Z","publisher":{"@type":"Organization","name":"NCAA.com","logo":{"@type":"ImageObject","url":"https:\/\/www.ncaa.com\/modules\/custom\/casablanca_content\/img\/meta\/ncaa.60.png","width":61,"height":60}},"description":"Here is the DII college football schedule for every week and game times of the 2020-21 season.","image":{"@type":"ImageObject","url":"https:\/\/www.ncaa.com\/_flysystem\/public-s3\/styles\/large_16x9\/public-s3\/images\/2020-10\/Ahmad-Lewis-South-Dakota-Mines-football.jpeg?h=7ee21c69&amp;itok=sfsi0EKW"},"mainEntityOfPage":"https:\/\/www.ncaa.com\/news\/football\/article\/2020-10-27\/2020-dii-football-schedule-dates-times-matchups","thumbnailUrl":"https:\/\/www.ncaa.com\/_flysystem\/public-s3\/images\/2020-10\/Ahmad-Lewis-South-Dakota-Mines-football.jpeg","articleSection":"article","author":{"@type":"Person","name":"Zach Pekale | NCAA.com"},"creator":{"@type":"Person","name":"Zach Pekale | NCAA.com"},"keywords":["College Football","college football schedule","DII football","DII football schedule"]}</script>
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"WebPage","url":"https:\/\/www.ncaa.com\/news\/football\/article\/2020-10-27\/2020-dii-football-schedule-dates-times-matchups","dateCreated":"2020-10-27T12:10:00Z","datePublished":"2020-10-27T12:11:15Z","dateModified":"2020-10-27T12:11:15Z","publisher":{"@type":"Organization","name":"NCAA.com","logo":{"@type":"ImageObject","url":"https:\/\/www.ncaa.com\/modules\/custom\/casablanca_content\/img\/meta\/ncaa.60.png","width":61,"height":60}},"headline":"2020 DII football schedule: Dates, times, matchups","description":"Here is the DII college football schedule for every week and game times of the 2020-21 season.","image":{"@type":"ImageObject","url":"https:\/\/www.ncaa.com\/_flysystem\/public-s3\/styles\/large_16x9\/public-s3\/images\/2020-10\/Ahmad-Lewis-South-Dakota-Mines-football.jpeg?h=7ee21c69&amp;itok=sfsi0EKW"},"author":{"@type":"Person","name":"Zach Pekale | NCAA.com"},"creator":{"@type":"Person","name":"Zach Pekale | NCAA.com"},"thumbnailUrl":"https:\/\/www.ncaa.com\/_flysystem\/public-s3\/styles\/large_16x9\/public-s3\/images\/2020-10\/Ahmad-Lewis-South-Dakota-Mines-football.jpeg?h=7ee21c69&amp;itok=sfsi0EKW","keywords":["College Football","college football schedule","DII football","DII football schedule"]}</script>
<meta name="title" property="title" content="2020 DII football schedule: Dates, times, matchups | NCAA.com" />
<meta name="url" property="url" content="https://www.ncaa.com/news/football/article/2020-10-27/2020-dii-football-schedule-dates-times-matchups" />
<meta name="image" property="image" content="https://www.ncaa.com/_flysystem/public-s3/styles/large_16x9/public-s3/images/2020-10/Ahmad-Lewis-South-Dakota-Mines-football.jpeg?h=7ee21c69&amp;itok=sfsi0EKW" />
<meta name="og:image" property="og:image" content="https://www.ncaa.com/_flysystem/public-s3/styles/large_16x9/public-s3/images/2020-10/Ahmad-Lewis-South-Dakota-Mines-football.jpeg?h=7ee21c69&amp;itok=sfsi0EKW" />
<meta name="og:title" property="og:title" content="2020 DII football schedule: Dates, times, matchups" />
<meta name="og:description" property="og:description" content="Here is the DII college football schedule for every week and game times of the 2020-21 season." />
<meta name="og:url" property="og:url" content="https://www.ncaa.com/news/football/article/2020-10-27/2020-dii-football-schedule-dates-times-matchups" />
<meta name="og:type" property="og:type" content="article" />
<meta name="twitter:image" property="twitter:image" content="https://www.ncaa.com/_flysystem/public-s3/styles/large_16x9/public-s3/images/2020-10/Ahmad-Lewis-South-Dakota-Mines-football.jpeg?h=7ee21c69&amp;itok=sfsi0EKW" />
<meta name="twitter:title" property="twitter:title" content="2020 DII football schedule: Dates, times, matchups" />
<meta name="twitter:description" property="twitter:description" content="Here is the DII college football schedule for every week and game times of the 2020-21 season." />
<meta name="twitter:url" property="twitter:url" content="https://www.ncaa.com/news/football/article/2020-10-27/2020-dii-football-schedule-dates-times-matchups" />
<meta name="twitter:site" property="twitter:site" content="@NCAA" />
<meta name="twitter:card" property="twitter:card" content="summary_large_image" />
<meta name="twitter:site:id" property="twitter:site:id" content="31122496" />
<link rel="dns-prefetch" href="//fastlane.rubiconproject.com" />
<link rel="dns-prefetch" href="//optimized-by.rubiconproject.com" />
<link rel="dns-prefetch" href="//ads.rubiconproject.com" />
<link rel="dns-prefetch" href="//aax.amazon-adsystem.com" />
<link rel="dns-prefetch" href="//c.amazon-adsystem.com" />
<link rel="dns-prefetch" href="//rtax.criteo.com" />
<link rel="dns-prefetch" href="//static.criteo.net" />
<link rel="dns-prefetch" href="//bidder.criteo.com" />
<link rel="dns-prefetch" href="//platform.twitter.com" />
<link rel="dns-prefetch" href="//ib.adnxs.com" />
<link rel="dns-prefetch" href="//prebid.adnxs.com" />
<link rel="preconnect" href="https://data.ncaa.com" />
<link rel="preconnect" href="https://fonts.googleapis.com" />
<link rel="preconnect" href="https://fonts.gstatic.com" />
<link rel="preconnect" href="https://i.turner.ncaa.com" />
<link rel="preconnect" href="https://turnip.cdn.turner.com" />
<link rel="prefetch" href="/themes/custom/bespin/assets/fonts/Geogrotesque-Md.woff" />
<link rel="prefetch" href="/themes/custom/bespin/assets/fonts/Geogrotesque-SmBd.woff" />
<link rel="prefetch" href="/themes/custom/bespin/assets/fonts/Geogrotesque-Rg.woff" />
<link rel="prefetch" href="/themes/custom/bespin/assets/fonts/Geogrotesque-Bd.woff" />
<link rel="apple-touch-icon" sizes="76x76" href="/apple-touch-icon.png" />
<link rel="icon" type="image/png" sizes="32x32" href="/favicon-32x32.png" />
<link rel="icon" type="image/png" sizes="16x16" href="/favicon-16x16.png" />
<link rel="manifest" href="/site.webmanifest" />
<link rel="mask-icon" href="/safari-pinned-tab.svg" color="#007dc7" />
<meta name="msapplication-TileColor" property="msapplication-TileColor" content="#da532c" />
<meta name="theme-color" property="theme-color" content="#ffffff" />
<link rel="shortcut icon" href="/favicon.ico" type="image/vnd.microsoft.icon" />
<link rel="amphtml" href="https://www.ncaa.com/news/football/article/2020-10-27/2020-dii-football-schedule-dates-times-matchups?amp" />

    <title>2020 DII football schedule: Dates, times, matchups | NCAA.com</title>
    <link rel="stylesheet" media="all" href="/modules/custom/casablanca_franchise/css/franchise-banner.css?v=master-454" />
<link rel="stylesheet" media="all" href="/modules/custom/casablanca_sports/css/sport-subnav.css?v=master-454" />
<link rel="stylesheet" media="all" href="/core/modules/system/css/components/ajax-progress.module.css?v=8.8.10" />
<link rel="stylesheet" media="all" href="/core/modules/system/css/components/align.module.css?v=8.8.10" />
<link rel="stylesheet" media="all" href="/core/modules/system/css/components/autocomplete-loading.module.css?v=8.8.10" />
<link rel="stylesheet" media="all" href="/core/modules/system/css/components/fieldgroup.module.css?v=8.8.10" />
<link rel="stylesheet" media="all" href="/core/modules/system/css/components/container-inline.module.css?v=8.8.10" />
<link rel="stylesheet" media="all" href="/core/modules/system/css/components/clearfix.module.css?v=8.8.10" />
<link rel="stylesheet" media="all" href="/core/modules/system/css/components/details.module.css?v=8.8.10" />
<link rel="stylesheet" media="all" href="/core/modules/system/css/components/hidden.module.css?v=8.8.10" />
<link rel="stylesheet" media="all" href="/core/modules/system/css/components/item-list.module.css?v=8.8.10" />
<link rel="stylesheet" media="all" href="/core/modules/system/css/components/js.module.css?v=8.8.10" />
<link rel="stylesheet" media="all" href="/core/modules/system/css/components/nowrap.module.css?v=8.8.10" />
<link rel="stylesheet" media="all" href="/core/modules/system/css/components/position-container.module.css?v=8.8.10" />
<link rel="stylesheet" media="all" href="/core/modules/system/css/components/progress.module.css?v=8.8.10" />
<link rel="stylesheet" media="all" href="/core/modules/system/css/components/reset-appearance.module.css?v=8.8.10" />
<link rel="stylesheet" media="all" href="/core/modules/system/css/components/resize.module.css?v=8.8.10" />
<link rel="stylesheet" media="all" href="/core/modules/system/css/components/sticky-header.module.css?v=8.8.10" />
<link rel="stylesheet" media="all" href="/core/modules/system/css/components/system-status-counter.css?v=8.8.10" />
<link rel="stylesheet" media="all" href="/core/modules/system/css/components/system-status-report-counters.css?v=8.8.10" />
<link rel="stylesheet" media="all" href="/core/modules/system/css/components/system-status-report-general-info.css?v=8.8.10" />
<link rel="stylesheet" media="all" href="/core/modules/system/css/components/tabledrag.module.css?v=8.8.10" />
<link rel="stylesheet" media="all" href="/core/modules/system/css/components/tablesort.module.css?v=8.8.10" />
<link rel="stylesheet" media="all" href="/core/modules/system/css/components/tree-child.module.css?v=8.8.10" />
<link rel="stylesheet" media="all" href="/modules/custom/casablanca_libraries/livefyre/css/ncaa-livefyre.css?v=1" />
<link rel="stylesheet" media="all" href="/modules/custom/casablanca_libraries/lazysizes/css/lazysizes.css?v=5.2.0" />
<link rel="stylesheet" media="all" href="/modules/custom/casablanca_stax/css/layout/layout-public.css?v=master-454" />
<link rel="stylesheet" media="all" href="/modules/custom/casablanca_tiles/css/tile-related-links.css?v=master-454" />
<link rel="stylesheet" media="all" href="/modules/custom/casablanca_tiles/css/tile-ad-slots.css?v=master-454" />
<link rel="stylesheet" media="all" href="/modules/custom/casablanca_tiles/css/tile-article.css?v=master-454" />
<link rel="stylesheet" media="all" href="/modules/custom/casablanca_tiles/css/tile-newsletter.css?v=master-454" />
<link rel="stylesheet" media="all" href="/modules/custom/casablanca_tiles/css/tile-links.css?v=master-454" />
<link rel="stylesheet" media="all" href="/modules/custom/casablanca_tiles/css/tile-live-video.css?v=master-454" />
<link rel="stylesheet" media="all" href="/modules/custom/casablanca_tiles/css/tile-ad.css?v=master-454" />
<link rel="stylesheet" media="all" href="/modules/custom/casablanca_tiles/css/tile-base.css?v=master-454" />
<link rel="stylesheet" media="all" href="/core/assets/vendor/jquery.ui/themes/base/core.css?v=1.12.1" />
<link rel="stylesheet" media="all" href="/core/assets/vendor/jquery.ui/themes/base/menu.css?v=1.12.1" />
<link rel="stylesheet" media="all" href="/core/assets/vendor/jquery.ui/themes/base/autocomplete.css?v=1.12.1" />
<link rel="stylesheet" media="all" href="/core/assets/vendor/jquery.ui/themes/base/datepicker.css?v=1.12.1" />
<link rel="stylesheet" media="all" href="/modules/contrib/anchor_link/css/anchor_link.css?v=8.8.10" />
<link rel="stylesheet" media="all" href="/modules/custom/casablanca_content/modules/casablanca_shortcodes/css/casablanca-shortcodes-icon.css?v=master-454" />
<link rel="stylesheet" media="all" href="/modules/custom/casablanca_content/css/paragraphs.css?v=master-454" />
<link rel="stylesheet" media="all" href="/modules/custom/casablanca_footer/css/footer.css?v=master-454" />
<link rel="stylesheet" media="all" href="/modules/custom/casablanca_social/modules/casablanca_social_hanger/css/social-hanger.css?v=master-454" />
<link rel="stylesheet" media="all" href="/modules/custom/casablanca_libraries/prettyselect/jquery.prettyselect.min.css?v=1.0.2" />
<link rel="stylesheet" media="all" href="/modules/custom/casablanca_libraries/table_responsive/css/table-responsive.css?v=1.0.1" />
<link rel="stylesheet" media="all" href="/modules/custom/casablanca_libraries/slick/css/slick.css?v=1.9.0" />
<link rel="stylesheet" media="all" href="/modules/custom/casablanca_libraries/slick/css/slick-theme.css?v=1.9.0" />
<link rel="stylesheet" media="all" href="/modules/custom/casablanca_articles/css/article-related.css?v=master-454" />
<link rel="stylesheet" media="all" href="/modules/custom/casablanca_articles/css/article-content.css?v=master-454" />
<link rel="stylesheet" media="all" href="/modules/custom/casablanca_core/css/gamePod.css?v=master-454" />
<link rel="stylesheet" media="all" href="/modules/contrib/paragraphs/css/paragraphs.unpublished.css?v=master-454" />
<link rel="stylesheet" media="all" href="/modules/custom/casablanca_nav/css/ncaa-nav.css?v=master-454" />
<link rel="stylesheet" media="all" href="/core/assets/vendor/jquery.ui/themes/base/theme.css?v=1.12.1" />
<link rel="stylesheet" media="all" href="/modules/custom/casablanca_scoreboard/css/ncaa-conference-selector.css?v=master-454" />
<link rel="stylesheet" media="all" href="/modules/custom/casablanca_scoreboard/css/ncaa-datenav.css?v=master-454" />
<link rel="stylesheet" media="all" href="/modules/custom/casablanca_scoreboard/css/ncaa-scoreboard.css?v=master-454" />
<link rel="stylesheet" media="all" href="/themes/custom/bespin/css/main.css?v=master-454" />

    <script type="application/json" data-drupal-selector="drupal-settings-json">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</script>

<!--[if lte IE 8]>
<script src="/core/assets/vendor/html5shiv/html5shiv.min.js?v=3.7.3"></script>
<![endif]-->
<script src="/core/assets/vendor/jquery/jquery.min.js?v=3.4.1"></script>
<script src="/core/assets/vendor/underscore/underscore-min.js?v=1.8.3"></script>
<script src="/core/assets/vendor/jquery/jquery-htmlprefilter-3.5.0.js?v=3.4.1"></script>
<script src="/core/misc/drupalSettingsLoader.js?v=8.8.10"></script>
<script src="/core/misc/drupal.js?v=8.8.10"></script>
<script src="/core/misc/drupal.init.js?v=8.8.10"></script>
<script src="/modules/custom/casablanca_libraries/prism/psm.ie.min.js?v=1.2.1"></script>
<script src="/modules/custom/casablanca_libraries/user-consent/js/min/user-consent.min.js?v=3.0.3"></script>
<script src="/modules/custom/casablanca_core/js/dist/constants.min.js?v=master-454"></script>
<script src="/modules/custom/casablanca_core/js/dist/utils.min.js?v=master-454"></script>
<script src="/modules/custom/casablanca_analytics/js/dist/ncaa_consent.min.js?v=master-454"></script>

  
  <script>(window.BOOMR_mq=window.BOOMR_mq||[]).push(["addVar",{"rua.upush":"false","rua.cpush":"true","rua.upre":"false","rua.cpre":"false","rua.uprl":"false","rua.cprl":"false","rua.cprf":"false","rua.trans":"SJ-d6fd554a-1b9d-4e95-b6e4-da0215e3c224","rua.cook":"false","rua.ims":"false","rua.ufprl":"false","rua.cfprl":"false"}]);</script>
  <script>!function(a){var e="https://s.go-mpulse.net/boomerang/",t="addEventListener";if("False"=="True")a.BOOMR_config=a.BOOMR_config||{},a.BOOMR_config.PageParams=a.BOOMR_config.PageParams||{},a.BOOMR_config.PageParams.pci=!0,e="https://s2.go-mpulse.net/boomerang/";if(window.BOOMR_API_key="LHVF5-23BLM-GMX9K-U7LL4-PWYYG",function(){function n(e){a.BOOMR_onload=e&&e.timeStamp||(new Date).getTime()}if(!a.BOOMR||!a.BOOMR.version&&!a.BOOMR.snippetExecuted){a.BOOMR=a.BOOMR||{},a.BOOMR.snippetExecuted=!0;var i,_,o,r=document.createElement("iframe");if(a[t])a[t]("load",n,!1);else if(a.attachEvent)a.attachEvent("onload",n);r.src="javascript:void(0)",r.title="",r.role="presentation",(r.frameElement||r).style.cssText="width:0;height:0;border:0;display:none;",o=document.getElementsByTagName("script")[0],o.parentNode.insertBefore(r,o);try{_=r.contentWindow.document}catch(O){i=document.domain,r.src="javascript:var d=document.open();d.domain='"+i+"';void(0);",_=r.contentWindow.document}_.open()._l=function(){var a=this.createElement("script");if(i)this.domain=i;a.id="boomr-if-as",a.src=e+"LHVF5-23BLM-GMX9K-U7LL4-PWYYG",BOOMR_lstart=(new Date).getTime(),this.body.appendChild(a)},_.write("<bo"+'dy onload="document._l();">'),_.close()}}(),"".length>0)if(a&&"performance"in a&&a.performance&&"function"==typeof a.performance.setResourceTimingBufferSize)a.performance.setResourceTimingBufferSize();!function(){if(BOOMR=a.BOOMR||{},BOOMR.plugins=BOOMR.plugins||{},!BOOMR.plugins.AK){var e="true"=="true"?1:0,t="",n="nml5ubax2si4ax4zs4uq-f-4e92c5d7d-clientnsv4-s.akamaihd.net",i={"ak.v":"29","ak.cp":"548492","ak.ai":parseInt("356633",10),"ak.ol":"0","ak.cr":1,"ak.ipv":4,"ak.proto":"http/1.1","ak.rid":"43dc88f","ak.r":38533,"ak.a2":e,"ak.m":"dscx","ak.n":"essl","ak.bpcip":"107.23.218.0","ak.cport":41408,"ak.gh":"23.34.240.238","ak.quicv":"","ak.tlsv":"tls1.2","ak.0rtt":"","ak.csrc":"-","ak.acc":"reno","ak.t":"1603901225","ak.ak":"hOBiQwZUYzCg5VSAfCLimQ==khjJ/YNOY2FSIM8swBOu20GMD/ECzPPVRewIzHDvfZ4paluzJRmI2FXupGPsO46bkH05ojVtfqscXQFuIHCMJBlVMgUapiQPoRrRd2FIH0RzUJktnhFXty6xlRmqHbbVmvqOhAPTgu1zrAWZ3zkO0ik6/UC2Pd4TaKttlEzY8BqS9LoUYOuMKd3zuORX9BqevFHaTDCjMZ8Vjo9HmVc3docfpPhRhbXIc93+qEVqujUYkggwZRWVVSH0+gwAhtDIdqTWXsWhiu7w0526+lGGAEnfQv90WSrmEn3UsO5PLcLmHwa4+OCH+ISsDlVgVEsTrlMNY4poUNtqqPOjkWQdgPH+QVuTb5u5G5CZJMmrTL4InFVjwqyfxYA2B9UkG3V+dn/dSTrOaerdEZEvyRiEK2Ktka4yftL7xy/OjkRO6l8=","ak.pv":"153","ak.dpoabenc":""};if(""!==t)i["ak.ruds"]=t;var _={i:!1,av:function(e){var t="http.initiator";if(e&&(!e[t]||"spa_hard"===e[t]))i["ak.feo"]=void 0!==a.aFeoApplied?1:0,BOOMR.addVar(i)},rv:function(){var a=["ak.bpcip","ak.cport","ak.cr","ak.csrc","ak.gh","ak.ipv","ak.m","ak.n","ak.ol","ak.proto","ak.quicv","ak.tlsv","ak.0rtt","ak.r","ak.acc","ak.t"];BOOMR.removeVar(a)}};BOOMR.plugins.AK={akVars:i,akDNSPreFetchDomain:n,init:function(){if(!_.i){var a=BOOMR.subscribe;a("before_beacon",_.av,null,null),a("onbeacon",_.rv,null,null),_.i=!0}return this},is_complete:function(){return!0}}}}()}(window);</script></head>
  <body class="path-node page-node-type-article">
        <a href="#main-content" class="visually-hidden focusable skip-link">
      Skip to main content
    </a>
    
      <div class="dialog-off-canvas-main-canvas" data-off-canvas-main-canvas>
    <div id="ncaa-root" class="layout-container">
    <header role="header" class="header-main clearfix">
                    <div class="top-banner">
                <div class="dfp" id="ad_bnr_atf_01"></div><div id="ad_oop_float_01"></div>

            </div>
                        <div class="region region-header">
                <div id="scoreboardWidgetWrapper">
</div>

                <nav id="ncaa-navigation" class="ncaa-navigation"><div id="nav-hamburger" class="hamburger-navigation line"><span></span><span></span><span></span></div><div class="main-navigation-inner"><a class="icon ncaa-main-logo" href="/">NCAA.com</a><div class="menu-live-container"><a href="/liveschedule" class="main-menu-item-live">Live Video</a></div><div class="drawer-navigation-inner"><ul class="main-navigation"><li class="menu-item-home"><a href="/" class="main-menu-item icon-home">Home</a></li><li class="menu-item-expandable"><span class="main-menu-item icon-sports expandable">Sports</span><div class="sub-nav"><div class="sports-nav"><div class="season"><h4>Fall</h4><ul><li><span class="sport-txt">Cross Country</span><span class="sport-nav-carat"></span><div><span class="sport-gender"><a href="/sports/cross-country-men"><span class="short">M</span><span class="full">Men</span></a></span><span class="sport-gender"><a href="/sports/cross-country-women"><span class="short">W</span><span class="full">Women</span></a></span></div></li><li class="no-gen"><a href="/sports/fieldhockey" class="sport-link">Field Hockey</a></li><li class="no-gen"><a href="/sports/football" class="sport-link">Football</a></li><li><span class="sport-txt">Soccer</span><span class="sport-nav-carat"></span><div><span class="sport-gender"><a href="/sports/soccer-men"><span class="short">M</span><span class="full">Men</span></a></span><span class="sport-gender"><a href="/sports/soccer-women"><span class="short">W</span><span class="full">Women</span></a></span></div></li><li class="no-gen"><a href="/sports/volleyball-women" class="sport-link">Volleyball - W</a></li><li class="no-gen"><a href="/sports/waterpolo-men" class="sport-link">Water Polo - M</a></li></ul></div><div class="season"><h4>Winter</h4><ul><li><span class="sport-txt">Basketball</span><span class="sport-nav-carat"></span><div><span class="sport-gender"><a href="/sports/basketball-men"><span class="short">M</span><span class="full">Men</span></a></span><span class="sport-gender"><a href="/sports/basketball-women"><span class="short">W</span><span class="full">Women</span></a></span></div></li><li class="no-gen"><a href="/sports/bowling" class="sport-link">Bowling</a></li><li class="no-gen"><a href="/sports/fencing" class="sport-link">Fencing</a></li><li><span class="sport-txt">Gymnastics</span><span class="sport-nav-carat"></span><div><span class="sport-gender"><a href="/sports/gymnastics-men"><span class="short">M</span><span class="full">Men</span></a></span><span class="sport-gender"><a href="/sports/gymnastics-women"><span class="short">W</span><span class="full">Women</span></a></span></div></li><li><span class="sport-txt">Ice Hockey</span><span class="sport-nav-carat"></span><div><span class="sport-gender"><a href="/sports/icehockey-men"><span class="short">M</span><span class="full">Men</span></a></span><span class="sport-gender"><a href="/sports/icehockey-women"><span class="short">W</span><span class="full">Women</span></a></span></div></li><li class="no-gen"><a href="/sports/rifle" class="sport-link">Rifle</a></li><li class="no-gen"><a href="/sports/skiing" class="sport-link">Skiing</a></li><li><span class="sport-txt">Swimming &amp; Diving</span><span class="sport-nav-carat"></span><div><span class="sport-gender"><a href="/sports/swimming-men"><span class="short">M</span><span class="full">Men</span></a></span><span class="sport-gender"><a href="/sports/swimming-women"><span class="short">W</span><span class="full">Women</span></a></span></div></li><li><span class="sport-txt">Track &amp; Field (I)</span><span class="sport-nav-carat"></span><div><span class="sport-gender"><a href="/sports/trackfield-indoor-men"><span class="short">M</span><span class="full">Men</span></a></span><span class="sport-gender"><a href="/sports/trackfield-indoor-women"><span class="short">W</span><span class="full">Women</span></a></span></div></li><li class="no-gen"><a href="/sports/wrestling" class="sport-link">Wrestling</a></li></ul></div><div class="season"><h4>Spring</h4><ul><li class="no-gen"><a href="/sports/baseball" class="sport-link">Baseball</a></li><li class="no-gen"><a href="/sports/beach-volleyball" class="sport-link">Beach Volleyball</a></li><li><span class="sport-txt">Golf</span><span class="sport-nav-carat"></span><div><span class="sport-gender"><a href="/sports/golf-men"><span class="short">M</span><span class="full">Men</span></a></span><span class="sport-gender"><a href="/sports/golf-women"><span class="short">W</span><span class="full">Women</span></a></span></div></li><li><span class="sport-txt">Lacrosse</span><span class="sport-nav-carat"></span><div><span class="sport-gender"><a href="/sports/lacrosse-men"><span class="short">M</span><span class="full">Men</span></a></span><span class="sport-gender"><a href="/sports/lacrosse-women"><span class="short">W</span><span class="full">Women</span></a></span></div></li><li class="no-gen"><a href="/sports/rowing" class="sport-link">Rowing</a></li><li class="no-gen"><a href="/sports/softball" class="sport-link">Softball</a></li><li><span class="sport-txt">Tennis</span><span class="sport-nav-carat"></span><div><span class="sport-gender"><a href="/sports/tennis-men"><span class="short">M</span><span class="full">Men</span></a></span><span class="sport-gender"><a href="/sports/tennis-women"><span class="short">W</span><span class="full">Women</span></a></span></div></li><li><span class="sport-txt">Track &amp; Field (O)</span><span class="sport-nav-carat"></span><div><span class="sport-gender"><a href="/sports/trackfield-outdoor-men"><span class="short">M</span><span class="full">Men</span></a></span><span class="sport-gender"><a href="/sports/trackfield-outdoor-women"><span class="short">W</span><span class="full">Women</span></a></span></div></li><li class="no-gen"><a href="/sports/volleyball-men" class="sport-link">Volleyball - M</a></li><li class="no-gen"><a href="/sports/waterpolo-women" class="sport-link">Water Polo - W</a></li></ul></div></div></div></li><li><a href="/video" class="main-menu-item icon-on_demand">Video</a></li><li><a href="/march-madness-live/watch?cid=mml2020_ncaa_main_nav" class="main-menu-item icon-march_madness_live">March Madness Live</a></li><li class="menu-item-expandable"><span class="main-menu-item icon-tickets expandable">Tickets</span><div class="sub-nav"><div class="tickets-nav"><div class="col"><h4>NCAA Championships</h4><ul><li><a href="/tickets" class="sport-link">NCAA Championships</a></li><li><a href="/tickets/football/fcs" class="sport-link">FCS</a></li><li><a href="/tickets/volleyball-women/d1" class="sport-link">Women&#039;s Volleyball</a></li><li><a href="/tickets/basketball-men/d1" class="sport-link">Men&#039;s Basketball</a></li><li><a href="/tickets/basketball-women/d1" class="sport-link">Women&#039;s Basketball</a></li></ul></div><div class="col"><h4>Primesport Tickets
            <span>Affiliate Offers</span></h4><ul class="primesport"><li><a href="https://bit.ly/NCAAMBBT" class="sport-link external">NCAA Tournament</a></li><li><a href="https://bit.ly/NCAAMENSFF" class="sport-link external">Final Four</a></li><li><a href="https://bit.ly/NCAAWrestle" class="sport-link external">NCAA Wrestling Championships</a></li><li><a href="https://bit.ly/NCAAWFF" class="sport-link external">Women’s Final Four</a></li><li><a href="https://bit.ly/NCAAFrozen" class="sport-link external">Men’s Frozen Four</a></li></ul></div></div></div></li><li class="menu-item-expandable"><span class="main-menu-item icon-schools expandable">Schools</span><div class="sub-nav"><div id="ncaa-nav-schools" class="schools-nav"><button class="school-search-goto">All Schools</button><div class="school-autocomplete"><div class="school-finder-container"><div class="svg-icon-glass"><svg viewBox="0 0 16 16" xmlns="http://www.w3.org/2000/svg"><path d="M11.435 10.063h-.723l-.256-.247a5.92 5.92 0 0 0 1.436-3.87 5.946 5.946 0 1 0-5.946 5.947 5.92 5.92 0 0 0 3.87-1.436l.247.256v.722L14.637 16 16 14.637l-4.565-4.574zm-5.489 0c-2.278 0-4.116-1.839-4.116-4.117S3.668 1.83 5.946 1.83s4.117 1.839 4.117 4.116-1.84 4.117-4.117 4.117z" fill="#fff" fill-rule="evenodd"/></svg></div><div class="js-form-item form-item js-form-type-textfield form-item- js-form-item- form-no-label"><input placeholder="Search all schools" class="school-finder form-text" data-action="redirect" type="text" size="60" maxlength="128" /></div></div></div><div class="trending"><h4>Trending Schools</h4><ul><li><img class="school-icon lazyload" data-src="https://i.turner.ncaa.com/sites/default/files/images/logos/schools/bgl/gonzaga.svg"><a href="/schools/gonzaga">Gonzaga</a></li><li><img class="school-icon lazyload" data-src="https://i.turner.ncaa.com/sites/default/files/images/logos/schools/bgl/florida.svg"><a href="/schools/florida">Florida</a></li><li><img class="school-icon lazyload" data-src="https://i.turner.ncaa.com/sites/default/files/images/logos/schools/bgl/oklahoma.svg"><a href="/schools/oklahoma">Oklahoma</a></li><li><img class="school-icon lazyload" data-src="https://i.turner.ncaa.com/sites/default/files/images/logos/schools/bgl/virginia.svg"><a href="/schools/virginia">Virginia</a></li><li><img class="school-icon lazyload" data-src="https://i.turner.ncaa.com/sites/default/files/images/logos/schools/bgl/michigan-st.svg"><a href="/schools/michigan-st">Michigan St.</a></li></ul><ul><li><img class="school-icon lazyload" data-src="https://i.turner.ncaa.com/sites/default/files/images/logos/schools/bgl/tennessee.svg"><a href="/schools/tennessee">Tennessee</a></li><li><img class="school-icon lazyload" data-src="https://i.turner.ncaa.com/sites/default/files/images/logos/schools/bgl/florida-st.svg"><a href="/schools/florida-st">Florida St.</a></li><li><img class="school-icon lazyload" data-src="https://i.turner.ncaa.com/sites/default/files/images/logos/schools/bgl/southern-california.svg"><a href="/schools/southern-california">Southern California</a></li><li><img class="school-icon lazyload" data-src="https://i.turner.ncaa.com/sites/default/files/images/logos/schools/bgl/purdue.svg"><a href="/schools/purdue">Purdue</a></li><li><img class="school-icon lazyload" data-src="https://i.turner.ncaa.com/sites/default/files/images/logos/schools/bgl/bradley.svg"><a href="/schools/bradley">Bradley</a></li></ul></div></div></div></li><li><a href="http://www.shopncaasports.com/source/BM-NCAAcom-edit-topnav" class="main-menu-item icon-shop" target="_blank">Shop</a></li></ul></div></div></nav>
                
<div class="trending_bar_container ">
    <div class="trending_bar ">

        <div class="trending_bar__info trending_bar__wrapper">
            <div class="trending_bar__name">
                <h3 class="">TRENDING: </h3>
            </div>

                                    <div class="trending_bar__feed">
                                            <span class="trending_bar__icon none"></span>
                                                                <a href="https://www.ncaa.com/news/baseball/article/2020-10-27/which-players-have-won-both-college-world-series-and-mlb-world-series?utm_campaign=trending"><p>🏆 The players who have won a CWS and an MLB World Series</p></a>
                </div>
                            <div class="trending_bar__feed">
                                            <span class="trending_bar__icon none"></span>
                                                                <a href="https://www.ncaa.com/news/basketball-men/article/2020-02-18/march-madness-365-andy-katz-podcast?utm_campaign=trending"><p>🎙 SEC preview on new March Madness 365 podcast </p></a>
                </div>
                            <div class="trending_bar__feed">
                                            <span class="trending_bar__icon none"></span>
                                                                <a href="https://www.ncaa.com/news/basketball-men/article/2020-10-27/15-contenders-julius-erving-award-nations-best-small-forward?utm_campaign=trending"><p>15 contenders for the Julius Erving Award</p></a>
                </div>
                            </div>
    </div>
</div>

                
                <div data-drupal-messages-fallback class="hidden"></div>

    </div>

    </header>
    <main role="main" class="clearfix">
        <a id="main-content" tabindex="-1"></a>
        <div id="ncaa-content" class="layout-content">
                                <div id="block-bespin-content">
    
        
            

<nav class="sport-subnav content-header">
    <div class="subnav-heading">
        <h3>Division II</h3>
        <h2 class="page-title">Football</h2>
    </div>
        <aside class="subnav-divisions">
        <select id="subnav-division-selector" data-sport="football-d2">
                    <option value="fbs">FBS</option>
                    <option value="fcs">FCS</option>
                    <option value="d2" selected="selected">DII</option>
                    <option value="d3">DIII</option>
                </select>
    </aside>
        <div class="subnav-main">
        <div id="subnav-flex-menu" class="subnav-menu-items">
                                        <a href="/sports/football/d2" data-menu-id="0" target="_self">Home</a>
                                                        <a href="/scoreboard/football/d2" data-menu-id="1" target="_self">Scores</a>
                                                        <a href="/brackets/football/d2" data-menu-id="2" target="_self">Bracket</a>
                                                        <a href="/rankings/football/d2" data-menu-id="3" target="_self">Rankings</a>
                                                        <a href="/stats/football/d2" data-menu-id="4" target="_self">Stats</a>
                                                        <a href="/video/football" data-menu-id="5" target="_self">Video</a>
                                                        <a href="/history/football/d2" data-menu-id="6" target="_self">History</a>
                                                        <a href="http://web1.ncaa.org/NCAATV/exec/query" data-menu-id="7" target="_blank">BROADCAST SCHEDULE</a>
                                        </div>
        <div class="subnav-ellipsis" style="display: none;"></div>
        <div id="subnav-overflow" class="overflow-menu"></div>
        <hr class="divider"/>
    </div>
        </nav>

    
    
    <style type="text/css">
    .non-sponsorship-line {
        border-bottom: 4px solid #818181!important;
    }
    .non-sponsor-content-ad {
        border-top-color: #818181!important;
    }
    </style>
    <figure class="franchise-block-container franchise-banner-nofranch">
            <div class="non-sponsorship-line">
                <div class="non-sponsor-content-ad">
                    <div class="sponsor-text"  style="display: block">PRESENTED BY</div>
                    <div class="dfp" id="ad_ns_atf_01"></div>
                </div>
            </div>
    </figure>










    <div class="layout--has-sidebar has-banner">
        <article role="article" class="article-content clearfix layout--content-left">
            <header>
                                    <div class="article-flag"><img src="https://www.ncaa.com/modules/custom/casablanca_core/img/sportbanners/football.svg" alt="football-d2 flag" /></div>
                                <div class="meta">
                    <h4>Zach Pekale | NCAA.com | October 27, 2020</h4>
                    <h1 class="headline">2020 DII football schedule: Dates, times, matchups</h1>
                </div>
            </header>
            <div class="article-body node__content">
                <div class="primary-media">
    <div class="paragraph-image">
                <img class="lazyload" data-src="https://www.ncaa.com/_flysystem/public-s3/styles/original/public-s3/images/2020/10/01/Ahmad-Lewis-South-Dakota-Mines-football.jpeg?itok=o1U_hsUN" alt="South Dakota Mines running back Ahmad Lewis ran for more than 1,300 yards in 2019."/>
                    <span class="paragraph-image__caption">South Dakota Mines is one of 10 DII football teams playing a game in 2020.</span>
            </div>
</div>
                
    <div class="ncaa-share-hanger">
    <label>Share</label>
    <ul>
        <li>
            <a id="social-share-facebook" data-url="https://www.ncaa.com/news/football/article/2020-10-27/2020-dii-football-schedule-dates-times-matchups" data-shareto="facebook" class="sharebutton icon-social-facebook" href="https://www.facebook.com/sharer/sharer.php?u=https://www.ncaa.com/news/football/article/2020-10-27/2020-dii-football-schedule-dates-times-matchups" title="Share on Facebook" target="_blank">
                <img src="/modules/custom/casablanca_social/modules/casablanca_social_hanger/img/social-facebook.svg" width="30px" height="30px" />
            </a>
        </li>
        <li>
            <a id="social-share-twitter" data-shareto="twitter" class="sharebutton icon-social-twitter" href="https://twitter.com/home?status=https://www.ncaa.com/news/football/article/2020-10-27/2020-dii-football-schedule-dates-times-matchups" title="Share on Twitter" target="_blank">
                <img src="/modules/custom/casablanca_social/modules/casablanca_social_hanger/img/social-twitter.svg" width="30px" height="30px" />
            </a>
        </li>
    </ul>
</div>
                <div></div>
                <div>
<p>Here is the 2020 Division II college football schedule and game times for every contest scheduled through Saturday, Nov. 7.</p>

<p>This story will continue to be updated throughout the season. <a href="https://www.ncaa.com/news/football/article/2020-09-23/guide-dii-football-2020" target="_blank" title="">Click or tap here for the complete guide to DII football in 2020.</a></p>

<h2>DII college football schedule: Game times, matchups</h2>

<p><em>All times Eastern. All schedules subject to change.</em></p>

<h3><strong>Week 6</strong></h3>

<p><strong>Saturday, Oct. 31</strong></p>

<p><a href="https://admin.ncaa.com/game/5406584" target="_blank" title="">Nebraska-Kearney at Pittsburg State | 2 p.m.</a><br />
<a href="https://admin.ncaa.com/game/4899014" target="_blank" title="">Western Colorado at Stephen F. Austin | 3 p.m.</a><br />
<a href="https://admin.ncaa.com/game/4661143" target="_blank" title="">Missouri Western at Central Arkansas | 4 p.m.</a><br />
<a href="https://admin.ncaa.com/game/4532241" target="_blank" title="">Chadron State at South Dakota Mines | 6 p.m.</a><br />
North American at West Texas A&amp;M | 7 p.m.</p>

<div data-align="none" data-caption="" data-embed-button="embed_media" data-entity-embed-display="view_mode:media.embedded" data-entity-id="76751" data-entity-type="media" data-entity-uuid="c7ca0c66-9bb4-47c2-b32c-ad245237f69c" data-langcode="" class="embedded-entity"><div>
    
                        
            <div><p class="text-align-center"><a href="https://www.ncaa.com/sports/football/d2?utm_campaign=inline-article-asset" target="_blank" title=""><strong>LATEST DII FOOTBALL NEWS</strong></a></p>

<p data-entity-type="" data-entity-uuid="" style="text-align: center;"><span><img alt="" data-entity-type="" data-entity-uuid="" src="https://www.ncaa.com/sites/default/files/public/files/west-florida-gif.gif" /><span title="Click and drag to resize">​</span></span></p>

<p data-entity-type="" data-entity-uuid="" style="text-align: center;"><strong>DII FOOTBALL GUIDE: <a href="https://www.ncaa.com/news/football/article/2020-09-23/guide-dii-football-2020?utm_campaign=links-bundle-asset" target="_blank">Everything you need to know about the 2020 season</a><br />
 2019 TOURNAMENT: <a href="https://www.ncaa.com/news/football/article/2019-12-02/dii-football-championship-bracket-schedule-scores-tournament?utm_campaign=links-bundle-asset" target="_blank">West Florida wins first national championship</a> | <a href="https://www.ncaa.com/brackets/football/d2/2019?utm_campaign=links-bundle-asset" target="_blank" title="">Interactive bracket</a> </strong><br />
<strong>DII BOWL RESULTS: <a href="https://www.ncaa.com/news/football/article/2019-12-03/dii-college-football-bowl-tracker?utm_campaign=links-bundle-asset" target="_blank" title="">Scores from each of the 4 DII bowl games</a></strong><br />
<strong>TOURNEY FAQS: <a href="https://www.ncaa.com/news/football/article/2019-10-22/dii-football-bracket-changes-2019-explained?utm_campaign=links-bundle-asset" target="_blank" title="">New bracket format, explained</a> | <a href="https://www.ncaa.com/news/football/article/2019-04-23/how-dii-football-championship-works-history-and-faqs?utm_campaign=links-bundle-asset" target="_blank">How the tourney works</a> <br />
HARLON HILL TROPHY: <a href="https://www.ncaa.com/news/football/article/2019-11-27/essential-guide-harlon-hill-trophy?utm_campaign=links-bundle-asset" target="_blank" title="">A complete history </a>| <a href="https://www.ncaa.com/news/football/article/2019-12-20/slippery-rocks-roland-rivers-iii-wins-2019-harlon-hill-trophy?utm_campaign=links-bundle-asset" target="_blank" title="">Rivers III wins 2019 award</a><br />
DII HISTORY: <a href="https://www.ncaa.com/news/football/article/2019-10-10/11-most-played-rivalries-dii-football-history?utm_campaign=links-bundle-asset" target="_blank">Most played rivalries</a> | <a href="https://www.ncaa.com/news/football/article/2019-10-16/winningest-teams-dii-football-history?utm_campaign=links-bundle-asset" target="_blank">Winningest teams</a> | <a href="https://www.ncaa.com/news/football/article/2018-10-02/dii-football-programs-most-ncaa-dii-national-championships?utm_campaign=links-bundle-asset" target="_blank">Championship history</a> </strong></p>
</div>
      
            </div>
</div>


<h3><strong>Week 7</strong></h3>

<p><strong>Saturday, Nov. 7</strong></p>

<p><a href="https://www.ncaa.com/game/4700509" target="_blank" title="">Western Colorado at Colorado Mesa | TBA</a><br />
<a href="https://www.ncaa.com/game/4532242" target="_blank" title="">South Dakota Mines at Black Hills State | 3 p.m.</a><br />
<a href="https://www.ncaa.com/game/5225869" target="_blank" title="">Chadron State at Nebraska-Kearney | 4 p.m.</a><br />
<a href="https://www.ncaa.com/game/4295313" target="_blank" title="">Angelo State at Abilene Christian | 4 p.m.</a><br />
<a href="https://www.ncaa.com/game/5406585" target="_blank" title="">Pittsburg State at Missouri Western | 4 p.m.</a></p>

<h2>2020 DII college football scores</h2>

<h3>Week 1</h3>

<p><strong>Saturday, Sept. 26</strong></p>

<p><a href="https://www.ncaa.com/game/4532247" target="_blank" title=""><strong>Angelo State 21</strong>, West Texas A&amp;M 10</a></p>

<h3>Week 2</h3>

<p><strong>Saturday, Oct. 3</strong></p><div class="ncaa-dfp-dynamic"></div>

<p><a href="https://www.ncaa.com/game/4060930" target="_blank" title=""><strong>Stephen F. Austin 34</strong>, West Texas A&amp;M 6</a></p>

<h3><strong>Week 3</strong></h3>

<p><strong>Saturday, Oct. 10</strong></p>

<p><a href="https://www.ncaa.com/game/4532243" target="_blank" title=""><strong>Colorado Mesa 10</strong>, Chadron State 7 (OT) </a><br />
<a href="https://www.ncaa.com/game/4532238" target="_blank"><strong>South Dakota Mines 34</strong>, Black Hills State 17</a></p>

<h3><strong>Week 4</strong></h3>

<p><strong>Saturday, Oct. 17</strong></p>

<p><a href="https://www.ncaa.com/game/4532244" target="_blank" title=""><strong>Colorado Mesa 56</strong>, Black Hills State 7</a><br />
<a href="https://admin.ncaa.com/game/4959884" target="_blank" title=""><strong>Stephen F. Austin 31</strong>, Angelo State 12</a><br />
<a href="https://www.ncaa.com/game/4532239" target="_blank" title=""><strong>Chadron State 41</strong>, South Dakota Mines 25</a></p>

<h3><strong>Week 5</strong></h3>

<p><strong>Saturday, Oct. 24</strong></p>

<p><a href="https://www.ncaa.com/game/4532240" target="_blank" title=""><strong>South Dakota Mines 24</strong>, Colorado Mesa 9</a><br />
<a href="https://www.ncaa.com/game/4532246" target="_blank" title=""><strong>West Texas A&amp;M 34</strong>,</a> <a href="https://www.ncaa.com/game/4532246" target="_blank" title="">Angelo State 27</a></p>

<h2>DII football championship information</h2>

<p>While teams can participate in a fall football season, there will not be a DII football championship in 2020. The <a href="https://www.ncaa.com/news/ncaa/article/2020-08-05/ncaa-division-ii-cancels-2020-fall-championships" target="_blank" title="">Division II Presidents Council announced on Aug. 5 that all seven DII fall championships are canceled</a>.</p>

<p>Here is the recent history of the DII football championship:</p>

<table border="1" cellpadding="1" cellspacing="1" style="width: 500px;">
	<thead>
		<tr>
			<th scope="col">YEAR</th>
			<th scope="col" style="width: 122px;">CHAMPION</th>
			<th scope="col" style="width: 61px;">SCORE</th>
			<th scope="col" style="width: 104px;">RUNNER-UP</th>
			<th scope="col" style="width: 81px;">SITE</th>
		</tr>
	</thead>
	<tbody>
		<tr>
			<td>2019</td>
			<td style="width: 122px;"><a href="https://www.ncaa.com/game/3909055" target="_blank" title="">West Florida</a></td>
			<td style="width: 61px;">48-40</td>
			<td style="width: 104px;">Minnesota State</td>
			<td style="width: 81px;">McKinney, Tex.</td>
		</tr>
		<tr>
			<td>2018</td>
			<td style="width: 122px;"><a href="https://www.ncaa.com/brackets/football/d2/2018" target="_blank" title="">Valdosta State</a></td>
			<td style="width: 61px;">49-47</td>
			<td style="width: 104px;">Ferris State</td>
			<td style="width: 81px;">McKinney, Tex.</td>
		</tr>
		<tr>
			<td>2017</td>
			<td style="width: 122px;"><a href="http://www.ncaa.com/interactive-bracket/football/d2/2017">Texas A&amp;M-Commerce</a></td>
			<td style="width: 61px;">37-27</td>
			<td style="width: 104px;">West Florida</td>
			<td style="width: 81px;">Kansas City, Kan.</td>
		</tr>
		<tr>
			<td>2016</td>
			<td style="width: 122px;"><a href="http://www.ncaa.com/interactive-bracket/football/d2/2016">Northwest Missouri State</a></td>
			<td style="width: 61px;">29-3</td>
			<td style="width: 104px;">North Alabama</td>
			<td style="width: 81px;">Kansas City, Kan.</td>
		</tr>
		<tr>
			<td>2015</td>
			<td style="width: 122px;"><a href="http://www.ncaa.com/interactive-bracket/football/d2/2015" target="_blank" title="">Northwest Missouri State</a></td>
			<td style="width: 61px;">34-7</td>
			<td style="width: 104px;">Shepherd</td>
			<td style="width: 81px;">Kansas City, Kan.</td>
		</tr>
	</tbody>
</table>

</div>
                                    <aside class="author-info"><p><em>Zach Pekale is an alumnus of Arizona State University with a degree in sports journalism. He has worked for Arizona PBS, Arizona Sports 98.7 FM and the Cape Cod Baseball League. His writing has also appeared on FOX Sports, Bleacher Report and at the Associated Press. Follow him on Twitter <a href="http://www.twitter.com/@ZachPekale" target="_blank">@ZachPekale</a>.</em></p><p><em>The views on this page do not necessarily reflect the views of the NCAA or its member institutions.</em></p></aside>
                
                                <div class="article-related">
                    <div class="article-related-wrapper">
                                                <div class="article-related-slide">
                            <div class="article-related-thumb">
                                <img class="lazyload" data-src="https://www.ncaa.com/_flysystem/public-s3/styles/medium_16x9/public-s3/images/2020-10/LSU-tiger-mascot.jpg?h=a5f2f23a&amp;itok=7oVUeonX" alt=""/>
                            </div>
                            <div class="article-related-content">
                                <div class="article-related-content-text">
                                    <h3 class="article-related-title">2020-21 College Football Playoff: Schedule, dates and sites</h3>
                                    <div class="article-related-summary">Here are the dates and sites for the 2020 College Football Playoff semifinals and 2021 CFP national championship.</div>
                                </div>
                                <a class="article-related-cta" href="/news/football/article/2020-10-28/2020-21-college-football-playoff-schedule-dates-and-sites?utm_campaign=article-carousel">READ MORE</a>
                            </div>
                        </div>
                                                <div class="article-related-slide">
                            <div class="article-related-thumb">
                                <img class="lazyload" data-src="https://www.ncaa.com/_flysystem/public-s3/styles/medium_16x9/public-s3/images/2020-10/Indiana-football-2-point-conversion_0.jpg?h=85ec95a0&amp;itok=x8F_58fg" alt=""/>
                            </div>
                            <div class="article-related-content">
                                <div class="article-related-content-text">
                                    <h3 class="article-related-title">College football rankings after Week 8: Penn State falls, Ohio State climbs</h3>
                                    <div class="article-related-summary">Here are the AP Top 25 college football rankings and the biggest movers for Week 8 of the 2020 season.</div>
                                </div>
                                <a class="article-related-cta" href="/news/football/article/2020-10-26/college-football-rankings-after-week-8-penn-state-falls-ohio-state-climbs?utm_campaign=article-carousel">READ MORE</a>
                            </div>
                        </div>
                                                <div class="article-related-slide">
                            <div class="article-related-thumb">
                                <img class="lazyload" data-src="https://www.ncaa.com/_flysystem/public-s3/styles/medium_16x9/public-s3/images/2020-10/ohio-state-football-justin-fields-nebraska_2.jpg?h=10d202d3&amp;itok=KEYWm375" alt=""/>
                            </div>
                            <div class="article-related-content">
                                <div class="article-related-content-text">
                                    <h3 class="article-related-title">College football scores: Top 25 rankings, results for Week 9</h3>
                                    <div class="article-related-summary">Here are Top 25 rankings for Week 9 of the 2020 college football season. Find the rankings, schedule and scores here.</div>
                                </div>
                                <a class="article-related-cta" href="/news/football/article/2020-10-25/college-football-scores-top-25-rankings-results-week-9?utm_campaign=article-carousel">READ MORE</a>
                            </div>
                        </div>
                                            </div>
                    <div class="article-related-dots"></div>
                </div>
                            </div>
        </article>
        <section class="stax-layout layout-size--sidebar"><div class="stax-tier-outer">
<div class="stax-tier-inner wrap one-across">
    <div class="stax-tier-slot stax-tile" data-tile-type="ad" data-slot="1">
            <aside class="tile-ad">
    <h5>Advertisement</h5>
    <div class="dfp" id="ad_rect_atf_01"></div>
</aside>




    </div>
</div>
</div><div class="stax-tier-outer">
<div class="stax-tier-inner wrap one-across">
    <div class="stax-tier-slot stax-tile" data-tile-type="live_video" data-slot="1">
            <div class="liveVideoTile"></div>


    </div>
</div>
</div><div class="stax-tier-outer">
<div class="stax-tier-inner wrap one-across">
    <div class="stax-tier-slot stax-tile" data-tile-type="links" data-slot="1">
            <div class="tile-links">
    <ul class="tile-links-list">
    <h2 class="links_title">DII Football News</h2>
            <li class="title-link tile-link-article">
                            <a href="/news/football/article/2020-10-27/2020-dii-football-schedule-dates-times-matchups">2020 DII football schedule: Dates, times, matchups</a>
                    </li>
            <li class="title-link tile-link-article">
                            <a href="/news/football/article/2020-10-24/historic-dii-football-program-win-dii-cross-country-conference-champions-crowned">A historic DII football program win. DII cross country conference champions crowned. Here&#039;s what you need to know</a>
                    </li>
            <li class="title-link tile-link-article">
                            <a href="/news/football/article/2020-10-24/3-things-know-about-south-dakota-mines-victory-dii-football">3 things to know about South Dakota Mines&#039; victory in DII football</a>
                    </li>
            <li class="title-link tile-link-article">
                            <a href="/news/football/article/2020-10-17/ncaa-dii-news-rmac-football-dii-college-basketball-back">NCAA DII news: 5 takeaways from the week that was and what lies ahead</a>
                    </li>
            <li class="title-link tile-link-article">
                            <a href="/news/football/article/2020-10-17/dii-football-holst-johannsen-battle-rmac-glory">Holst&#039;s experience shines through in RMAC quarterback battle</a>
                    </li>
            <li class="title-link tile-link-article">
                            <a href="/news/football/article/2020-10-11/rmac-returns-dii-football-dii-basketball-preview">The RMAC returns to DII football. Here&#039;s how it went down and what lies ahead</a>
                    </li>
            <li class="title-link tile-link-article">
                            <a href="/news/football/article/2020-10-10/7-numbers-rmacs-first-dii-football-game-2020">7 numbers from the RMAC&#039;s first DII football game of 2020</a>
                    </li>
            <li class="title-link tile-link-article">
                            <a href="/news/football/article/2020-10-09/heres-what-you-need-know-week-3-dii-football-season">Here&#039;s what you need to know for Week 3 of the DII football season</a>
                    </li>
            <li class="title-link tile-link-article">
                            <a href="/news/basketball-men/article/2020-10-03/dii-college-basketball-contenders-and-dii-football-season">Early DII college basketball contenders and a look at next week&#039;s DII football slate</a>
                    </li>
            <li class="title-link tile-link-article">
                            <a href="/news/football/article/2020-09-26/3-observations-angelo-states-win-dii-football-opener">3 observations from Angelo State&#039;s win in the DII football opener</a>
                    </li>
        </ul>
</div>


    </div>
</div>
</div><div class="stax-tier-outer">
<div class="stax-tier-inner wrap one-across">
    <div class="stax-tier-slot stax-tile" data-tile-type="newsletter" data-slot="1">
            <div class="tile-newsletter">
    <div class="tile-newsletter-bg">
        <h3>Subscribe To Email Updates</h3>
        <p>Enter your information to receive emails about offers, promotions from NCAA.com and our partners</p>

        <label>Email Address</label>
        <input type="email" name="newsletter-field">
        <button class="tile-newsletter-signup submit-button blue-button" type="button">Sign Me Up</button>
    </div>
</div>


    </div>
</div>
</div><div class="stax-tier-outer">
<div class="stax-tier-inner wrap one-across">
    <div class="stax-tier-slot stax-tile" data-tile-type="article" data-slot="1">
            <article class="tile-article tile-container ">
        <a href="/news/football/article/2020-01-14/west-florida-wins-2019-dii-football-championship-record-setting-48">
        <div  class="tile-image-container  ratio16x9">
                            <img class="tile-image lazyload" data-src="https://www.ncaa.com/_flysystem/public-s3/styles/stax_large_content_tile/public-s3/images/2019-12/UWF-celebrate.jpeg?h=d399ad5e&amp;itok=taFzcCVC" alt=""/>
                    </div>
    </a>
        <a href="/news/football/article/2020-01-14/west-florida-wins-2019-dii-football-championship-record-setting-48">
        <h2 class="tile-headline">West Florida wins the 2019 DII football championship in a record-setting 48-40 thriller</h2>
    </a>
    <ul class="tile-related-links"></ul>
</article>


    </div>
</div>
</div><div class="stax-tier-outer">
<div class="stax-tier-inner wrap one-across">
    <div class="stax-tier-slot stax-tile" data-tile-type="article" data-slot="1">
            <article class="tile-article tile-container ">
        <a href="/news/football/article/2018-12-21/dii-football-programs-most-ncaa-dii-national-championships">
        <div  class="tile-image-container  ratio16x9">
                            <img class="tile-image lazyload" data-src="https://www.ncaa.com/_flysystem/public-s3/styles/stax_large_content_tile/public-s3/tile-images/article/Valdosta-State.jpg?itok=Jl8okT8b" alt=""/>
                    </div>
    </a>
        <div class="tile-info">
                <h3 class="tile-sport-label">DII football</h3>
                    </div>
        <a href="/news/football/article/2018-12-21/dii-football-programs-most-ncaa-dii-national-championships">
        <h2 class="tile-headline">DII football programs with the most NCAA DII national championships</h2>
    </a>
    <ul class="tile-related-links"></ul>
</article>


    </div>
</div>
</div></section>
</div>



    </div>


                    </div>

            </main>
    <footer role="footer" class="clearfix">
                        <nav role="navigation" aria-labelledby="block-ncaafooternavigationmenu-menu" id="block-ncaafooternavigationmenu">
            
  <h2 class="visually-hidden" id="block-ncaafooternavigationmenu-menu">NCAA Footer Navigation Menu</h2>
  

        
<div class="footer-ad clearfix">
    <div class="footer-wrapper">
                    <div id="ad_nfs_btf_01" class="dfp"></div>
            <div id="ad_nfs_btf_02" class="dfp"></div>
            <div id="ad_nfs_btf_03" class="dfp"></div>
            </div>
</div>
<div class="footer clearfix">
    <div class="footer-wrapper">
                            
                          <ul class="footer-menu clearfix">
                                                                    <li class="footer--links">
                <span class="footer-menu--link-category"> Featured Sections </span>
                                                                
                          <ul class="footer-menu clearfix footer--link">
                                                                    <li class="footer-menu--link-item">
                <a href="/march-madness" data-drupal-link-system-path="node/841330">March Madness</a>
                                          </li>
                                                        <li class="footer-menu--link-item">
                <a href="https://bracketchallenge.ncaa.com/">Bracket Challenge Game</a>
                                          </li>
                                                        <li class="footer-menu--link-item">
                <a href="/video" data-drupal-link-system-path="video">Video</a>
                                          </li>
                                                        <li class="footer-menu--link-item">
                <a href="/news/ncaa/article/2013-09-17/ncaa-championship-brackets" data-drupal-link-system-path="node/806746">Brackets</a>
                                          </li>
                                                        <li class="footer-menu--link-item">
                <a href="/news/ncaa/article/2013-09-17/ncaa-rankings" data-drupal-link-system-path="node/806748">Rankings</a>
                                          </li>
                                                        <li class="footer-menu--link-item">
                <a href="/newsletter-signup" data-drupal-link-system-path="newsletter-signup">Newsletters</a>
                                          </li>
                        </ul>
                  
                            </li>
                                                        <li class="footer--links">
                <span class="footer-menu--link-category"> Experience It Live </span>
                                                                
                          <ul class="footer-menu clearfix footer--link">
                                                                    <li class="footer-menu--link-item">
                <a href="/tickets" data-drupal-link-system-path="tickets">Championship Tickets</a>
                                          </li>
                                                        <li class="footer-menu--link-item">
                <a href="/exchange" data-drupal-link-system-path="node/840977">NCAA Ticket Exchange</a>
                                          </li>
                                                        <li class="footer-menu--link-item">
                <a href="https://www.primesport.com/about/ncaaexp?utm_source=ncaa.com&amp;utm_medium=referral&amp;utm_campaign=ncaa_experience-ncaa_web_bottom_navigation">The NCAA Experience</a>
                                          </li>
                                                        <li class="footer-menu--link-item">
                <a href="/travel">NCAA Travel</a>
                                          </li>
                                                        <li class="footer-menu--link-item">
                <a href="/tickets/basketball-men/d1" data-drupal-link-system-path="node/831931">DI Men&#039;s Basketball Tickets</a>
                                          </li>
                                                        <li class="footer-menu--link-item">
                <a href="/march-madness/schedule">March Madness Schedule</a>
                                          </li>
                                                        <li class="footer-menu--link-item">
                <a href="https://www.ncaa.com/ticket-terms">Ticket Terms</a>
                                          </li>
                        </ul>
                  
                            </li>
                                                        <li class="footer--links">
                <span class="footer-menu--link-category"> NCAA Championships </span>
                                                                
                          <ul class="footer-menu clearfix footer--link">
                                                                    <li class="footer-menu--link-item">
                <a href="/championships" data-drupal-link-system-path="championships">Championship Central</a>
                                          </li>
                                                        <li class="footer-menu--link-item">
                <a href="/shop">Championship Store</a>
                                          </li>
                                                        <li class="footer-menu--link-item">
                <a href="/final-four" data-drupal-link-system-path="node/841170">2020 Final Four</a>
                                          </li>
                                                        <li class="footer-menu--link-item">
                <a href="/womensfinalfour">2020 Women&#039;s Final Four</a>
                                          </li>
                                                        <li class="footer-menu--link-item">
                <a href="/frozenfour">2020 Frozen Four</a>
                                          </li>
                                                        <li class="footer-menu--link-item">
                <a href="/cws">2020 Men&#039;s College World Series</a>
                                          </li>
                        </ul>
                  
                            </li>
                                                        <li class="footer--links">
                <span class="footer-menu--link-category"> About the NCAA </span>
                                                                
                          <ul class="footer-menu clearfix footer--link">
                                                                    <li class="footer-menu--link-item">
                <a href="http://www.ncaa.org/">NCAA.org</a>
                                          </li>
                                                        <li class="footer-menu--link-item">
                <a href="http://www.ncaahallofchampions.org/index.php">Hall of Champions</a>
                                          </li>
                                                        <li class="footer-menu--link-item">
                <a href="http://www.ncaa.org/student-athletes/future">Eligibility Center</a>
                                          </li>
                                                        <li class="footer-menu--link-item">
                <a href="/news/ncaa/article/2011-02-25/corporate-champions-and-partners" data-drupal-link-system-path="node/807191">Corporate Champions &amp; Partners</a>
                                          </li>
                                                        <li class="footer-menu--link-item">
                <a href="/media" data-drupal-link-system-path="node/841187">Broadcast Media and Services</a>
                                          </li>
                                                        <li class="footer-menu--link-item">
                <a href="http://on.ncaa.com/2pAbX4M">Careers in College Athletics</a>
                                          </li>
                                                        <li class="footer-menu--link-item">
                <a href="/elite-90" data-drupal-link-system-path="node/841050">Elite 90</a>
                                          </li>
                        </ul>
                  
                            </li>
                        </ul>
                  
                <div class="footer-submenu clearfix">
            <ul class="footer-submenu">

                <li class="footer-submenu"><a href="/contact-us">Feedback</a></li>

                                  <li class="footer-submenu"><a href="/tos" target="_blank">Terms of Service</a></li>
                
                <li class="footer-submenu"><a href="/closed-captioning">Accessibility and Closed Captioning</a></li>

                <li class="footer-submenu">
                    <a id="cnn_cnsnt_trst">
                        <script type="text/javascript" src="//consent.truste.com/notice?domain=turner.com&c=cnn_cnsnt_trst&text=true&country=us"></script>
                        </a><img src="https://i.cdn.turner.com/cnn/.e/img/3.0/global/misc/logo_ad_choices_footer.png" alt="" border="0" class="cnn_ie6png" height="12" style="margin:0pt 0pt 0pt 4px;" width="12"/>
                </li>

                                  <li class="footer-submenu"><a href="/privacy" target="_blank">Privacy Policy</a></li>
                
                <li class="footer-submenu"><a href="/rss">RSS</a></li>
                <li class="footer-submenu privacy-link" tabindex=0><a style="cursor:pointer;" class="do-not-sell-link" >Do Not Sell My Personal Information</a></li>
            </ul>
        </div>
        <a href="http://www.turner.com" class="footer-logo" target="_blank">Turner</a>
        <div class="footer-copy">
            &copy; 2020 NCAA | Turner Sports Interactive, Inc. <br>
        NCAA.com is a part of Bleacher Report - Turner Sports Network, part of the Turner Sports and Entertainment Network.
        </div>
    </div>
</div>

  </nav>


                        <div class="mobile-persistent-bottom">
            <span id="bottom_sync">
    <span id="fw_bottom_sync" class="_fwph">
        <form id="_fw_form_fw_bottom_sync" style="display:none">
            <input class="fw_responsive" type="hidden" name="_fw_input_fw_bottom_sync" id="_fw_input_fw_bottom_sync"
                data-lvp="" data-mvp="" data-svp="slau=320x50_sync&w=320&h=50"
                value="">
        </form>
        <span id="_fw_container_fw_bottom_sync" class="_fwac">
            <div class="dfp" id="ad_bnr_atf_02"></div>
        </span>
    </span>
</span>
        </div>
            </footer>
</div>

  </div>

    
    <script src="/core/assets/vendor/jquery-once/jquery.once.min.js?v=2.2.0"></script>
<script src="/core/assets/vendor/backbone/backbone-min.js?v=1.2.3"></script>
<script src="/core/assets/vendor/jquery.ui/ui/data-min.js?v=1.12.1"></script>
<script src="/core/assets/vendor/jquery.ui/ui/disable-selection-min.js?v=1.12.1"></script>
<script src="/core/assets/vendor/jquery.ui/ui/form-min.js?v=1.12.1"></script>
<script src="/core/assets/vendor/jquery.ui/ui/labels-min.js?v=1.12.1"></script>
<script src="/core/assets/vendor/jquery.ui/ui/jquery-1-7-min.js?v=1.12.1"></script>
<script src="/core/assets/vendor/jquery.ui/ui/scroll-parent-min.js?v=1.12.1"></script>
<script src="/core/assets/vendor/jquery.ui/ui/tabbable-min.js?v=1.12.1"></script>
<script src="/core/assets/vendor/jquery.ui/ui/unique-id-min.js?v=1.12.1"></script>
<script src="/core/assets/vendor/jquery.ui/ui/version-min.js?v=1.12.1"></script>
<script src="/core/assets/vendor/jquery.ui/ui/escape-selector-min.js?v=1.12.1"></script>
<script src="/core/assets/vendor/jquery.ui/ui/focusable-min.js?v=1.12.1"></script>
<script src="/core/assets/vendor/jquery.ui/ui/ie-min.js?v=1.12.1"></script>
<script src="/core/assets/vendor/jquery.ui/ui/keycode-min.js?v=1.12.1"></script>
<script src="/core/assets/vendor/jquery.ui/ui/plugin-min.js?v=1.12.1"></script>
<script src="/core/assets/vendor/jquery.ui/ui/safe-active-element-min.js?v=1.12.1"></script>
<script src="/core/assets/vendor/jquery.ui/ui/safe-blur-min.js?v=1.12.1"></script>
<script src="/core/assets/vendor/jquery.ui/ui/widget-min.js?v=1.12.1"></script>
<script src="https://lightning.ncaa.com/launch/7be62238e4c3/d27aaa336a89/launch-8355f7a8c0c6.min.js"></script>
<script src="//cdn.livefyre.com/Livefyre.js"></script>
<script src="/modules/custom/casablanca_libraries/twitterwidgetjs/twitter-widgets.min.js?v=1.0.0"></script>
<script src="/modules/custom/casablanca_core/js/dist/polyfills.min.js?v=master-454"></script>
<script src="/modules/custom/casablanca_core/js/dist/ncaaUserAgent.min.js?v=master-454"></script>
<script src="/modules/custom/casablanca_core/js/dist/external-link-fixer.min.js?v=master-454"></script>
<script src="https://i.cdn.turner.com/ads/adfuel/ais/2.1/ncaa_3-ais.min.js"></script>
<script src="https://i.cdn.turner.com/ads/adfuel/adfuel-2.1.min.js"></script>
<script src="/modules/custom/casablanca_draco_dfp/js/dist/AdsManager.min.js?v=master-454"></script>
<script src="/themes/custom/bespin/js/ad-check.js?v=master-454"></script>
<script src="/modules/custom/casablanca_libraries/lazysizes/lazysizes.min.js?v=5.2.0"></script>
<script src="/modules/custom/casablanca_footer/js/dist/footer.min.js?v=master-454"></script>
<script src="/modules/custom/casablanca_social/modules/casablanca_social_hanger/js/dist/social-hanger.min.js?v=master-454"></script>
<script src="/modules/custom/casablanca_franchise/js/dist/franchise-banner-nofranch.min.js?v=master-454"></script>
<script src="/modules/custom/casablanca_libraries/prettyselect/js/min/jquery.prettyselect.min.js?v=1.0.2"></script>
<script src="/modules/custom/casablanca_sports/js/dist/sport-subnav.min.js?v=master-454"></script>
<script src="/modules/custom/casablanca_libraries/table_responsive/js/min/table-responsive.min.js?v=1.0.1"></script>
<script src="/modules/custom/casablanca_libraries/slick/slick.min.js?v=1.9.0"></script>
<script src="/modules/custom/casablanca_libraries/fitvids/js/min/jquery.fitvids.min.js?v=1.2.0"></script>
<script src="/modules/custom/casablanca_articles/js/dist/article-related.min.js?v=master-454"></script>
<script src="/modules/custom/casablanca_articles/js/dist/article-content.min.js?v=master-454"></script>
<script src="/modules/custom/casablanca_tiles/js/dist/tile-adslots.min.js?v=master-454"></script>
<script src="/modules/custom/casablanca_tiles/js/dist/tile-article.min.js?v=master-454"></script>
<script src="/modules/custom/casablanca_tiles/js/dist/tile-newsletter.min.js?v=master-454"></script>
<script src="/modules/custom/casablanca_tiles/js/dist/tile-links.min.js?v=master-454"></script>
<script src="/modules/custom/casablanca_libraries/babel-polyfill/babel-polyfill.min.js?v=1.0.1"></script>
<script src="/modules/custom/casablanca_tiles/js/dist/tile-live-video.min.js?v=master-454"></script>
<script src="/modules/custom/casablanca_nav/js/dist/casablanca-nav.min.js?v=master-454"></script>
<script src="/core/assets/vendor/jquery.ui/ui/position-min.js?v=1.12.1"></script>
<script src="/core/assets/vendor/jquery.ui/ui/widgets/menu-min.js?v=1.12.1"></script>
<script src="/core/assets/vendor/jquery.ui/ui/widgets/autocomplete-min.js?v=1.12.1"></script>
<script src="/modules/custom/casablanca_libraries/fuse/fuse.min.js?v=3.0.5"></script>
<script src="/modules/custom/casablanca_schools/js/dist/autocomplete.min.js?v=master-454"></script>
<script src="/core/assets/vendor/jquery.ui/ui/widgets/datepicker-min.js?v=1.12.1"></script>
<script src="/modules/custom/casablanca_libraries/handlebars/handlebars-v4.0.5.min.js?v=4.0.5"></script>
<script src="/modules/custom/casablanca_libraries/moment/moment.min.js?v=2.24.0"></script>
<script src="/modules/custom/casablanca_libraries/moment_timezone/moment-timezone-with-data-10-year-range.min.js?v=0.5.26"></script>
<script src="/modules/custom/casablanca_core/js/dist/handlebarsHelpers.min.js?v=master-454"></script>
<script src="/modules/custom/casablanca_scoreboard/js/dist/scoreboardWidget.min.js?v=master-454"></script>

  <script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam-cell.nr-data.net","licenseKey":"b4c08c65aa","applicationID":"103177932","transactionName":"MldQZkoDDUUAAk0NXwsdc1FMCwxYTiVLEUAEXm5cVwYGaiIOVxBCCl5eV0o+LVkFBG8NVRJxXVxMEAxaDQRLSQ4TW1dF","queueTime":0,"applicationTime":738,"atts":"HhBTEAIZHks=","errorBeacon":"bam-cell.nr-data.net","agent":""}</script></body>
</html>
